Upgrade to 3.9 sp2 (Scripting Error)

Topics applicable to newer version(s) of CMM-Manager (3.0+)
Post Reply
ken60
Power User
Power User
Posts: 98
Joined: Fri Mar 21, 2014 12:32 pm

Upgrade to 3.9 sp2 (Scripting Error)

Post by ken60 » Mon Feb 24, 2020 3:01 pm

After upgrade to 3.9 sp2 from 3.7 sp2, I have this error message
3.9 Update.png
You do not have the required permissions to view the files attached to this post.

ken60
Power User
Power User
Posts: 98
Joined: Fri Mar 21, 2014 12:32 pm

Re: Upgrade to 3.9 sp2

Post by ken60 » Mon Feb 24, 2020 3:35 pm

3.9 SP2 PH20, Uccserver_53000
The error message on other posted appeared right after cmm manager open. For a reason I don't get that error message any more but this error message instead
3.9sp2.JPG
Click OK then cmm manager open but will stop on 1 line for some scrip when execute a program
You do not have the required permissions to view the files attached to this post.

User avatar
CMM Guru
Moderator
Moderator
Posts: 92
Joined: Thu Feb 24, 2011 7:49 pm

Re: Upgrade to 3.9 sp2

Post by CMM Guru » Mon Feb 24, 2020 4:14 pm

This is the scripting engine dlls not registered error.

You can try installing as Admin, or manually register the dlls located at: “C:\Program Files\Common Files\Nikon\ScriptDebug”.

Using command line:

regsvr32.exe “C:\Program Files\Common Files\Nikon\ScriptDebug\pdm.dll”
regsvr32.exe “C:\Program Files\Common Files\Nikon\ScriptDebug\msdbg2.dll”

Please note that all CMM-Manager installs and upgrades required that you do it while logged as a user with *local* admin rights. In this case, you may have to right click the installer and Run as Administrator.

ken60
Power User
Power User
Posts: 98
Joined: Fri Mar 21, 2014 12:32 pm

Re: Upgrade to 3.9 sp2

Post by ken60 » Mon Feb 24, 2020 4:34 pm

Thank you Guru, I believe I upgraded the software as Administrator, if manually register is equivalent to auto install I will give it a try

ken60
Power User
Power User
Posts: 98
Joined: Fri Mar 21, 2014 12:32 pm

Re: Upgrade to 3.9 sp2

Post by ken60 » Mon Feb 24, 2020 7:38 pm

Re-install upgrade as Administrator and error gone, doesn't need manually register thanks


re-install

User avatar
CMM Guru
Moderator
Moderator
Posts: 92
Joined: Thu Feb 24, 2011 7:49 pm

Re: Upgrade to 3.9 sp2

Post by CMM Guru » Tue Feb 25, 2020 10:25 am

We are always happy to help!

User avatar
34Ford
Getting Started
Getting Started
Posts: 3
Joined: Wed Mar 25, 2020 10:04 am
Location: N.C.

Re: Upgrade to 3.9 sp2 (Scripting Error)

Post by 34Ford » Thu Mar 26, 2020 8:23 am

Gotta love forums, thanks Guru, worked for me.
Dennis

Post Reply